This East Coast third-party AWS Cloudfront node exhibited the same failure after the next major Omnistream software update. We have disabled Cloudfront caching until further notice. This resolves the issue for users. We simultaneously increased resources for Omnistream web servers to compensate and have not measured a detectable degradation of service for users as a result.
Posted May 30, 2024 - 09:08 EDT
Resolved
Third-party provider AWS is experiencing an issue with an US East Coast Cloudfront edge node, which is not providing cached assets (graphics, code) for Omnistream pages properly. This causes a blank white page to be displayed. We have bypassed AWS Cloudfront entirely for now. Access has been restored for affected users.
Posted May 27, 2024 - 13:24 EDT
Investigating
A subset of users see a white page when they log in. This appears to be associated with specific machines. It is not associated with specific user accounts, version of Chrome or location. This appears to be due to a change in CORS policy within the Chrome browser over the weekend. Engineering is investigating. Next update in one hour.